Sell Orders Completion Delay
Incident Report for Plum Fintech
Resolved
The issue has been fixed and the incident is now closed.

The money has now reached the customers' Primary Pockets.

Once again we would like to apologise for the inconvenience.
Posted May 24, 2022 - 15:23 BST
Identified
We are aware that some customers might experience a delay in the completion of their sell orders that were estimated to complete on May 20th.

Rest assured that the issue has been identified and is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe in the meantime.

We would like to apologise for the inconvenience caused.
Posted May 24, 2022 - 11:27 BST
This incident affected: 📈 Investments.