App Degraded Performance
Incident Report for Plum Fintech
Resolved
The root cause of the issue has been identified and fixed by our teams. The App performance is back to normal.

We would like to apologize for the inconvenience caused and once again assure you that the security of your funds was never compromised.

Shall you need anything, please do not hesitate to reach out!
Posted May 11, 2022 - 15:32 BST
Investigating
While monitoring after the initial fix, we noticed another short occurrence of degraded App performance. The App accessibility has been restored once again but we are investigating further.
Posted May 11, 2022 - 15:03 BST
Monitoring
We were experiencing some connectivity issues within the App today May 11th from 12h20 to 12h42 GMT that translated into degraded performance. It may have prevented you from logging in, taking some actions within the app, and loading your pockets' balances.

The issue is now resolved and the full App accessibilities are restored.

Rest assured that the security of your money was never compromised.

We're really sorry for the inconvenience!
Posted May 11, 2022 - 13:01 BST
This incident affected: Plum application.